AR Scene Positioning?

I have a relatively simple scene with a tree and a camera. The tree is not placed at the middle of the play area, but toward the back. When I try to play my scene in AR and I choose a spot on the floor where I would like the tree to be, it appears and then kind of scoots off the the side and a bit behind me.
How can I choose a particular reference point of my scene (ie, the tree) and have it placed exactly on the floor where I choose the AR scene to be? And ideally I would like it placed from the point of view of my camera (same side of the tree facing me, for example).


Hi @Will,

I tried your CoSpace and it worked fine for me - the placement appeared as expected (though I then shrank it down to fit on my table). I’m using a Samsung Galaxy S7 which supports ARCore.

Are you using one of the devices which supports ARCore or ARkit?


Hi @techleapnz,
I’ll confirm when I get into work Tuesday (where my iPad is), but this is a new iPad as of December, so I’m fairly confident it’s supported. I know it’s worked okay for other AR scenes…
How does it look if you don’t shrink the scene? Can you place it on the floor, as opposed to a table? The tree is meant to look large (taller than most rooms, though for the people I’ll be showing it to we’ll be in a two-story room).

So I’m using a 11-in. iPad Pro, which is listed as compatible.
I just tried again and the tree at least appears in front of me as it should, but the entire scene is at least a couple of feet ABOVE the ground (I even tried stooping to scan close to the ground, but it made no difference). Also tried shrinking the scene, and the positional freezing still happens (moving the iPad around doesn’t change the view, as if the camera is “stuck”).

Yes, I get the same result - the floor plane is a couple of feet above the ground.

Thanks for confirming! Maybe I’ll remove the “grass” if it helps disguise the wonky floor plane (assuming no fix).

When you start the animation after clicking the tree (full size scene) and luck replicating the camera “freeze”? That’s the part that’s really causing me issues.
EDIT: sorry, as per my other thread. (maybe I should have just kept it all in one thread, lol)

No problem with positional camera freezing on my end.

Squirrel makes it down the tree and does its dance? Hmm. You mentioned being on a Samsung phone? I wonder if this is something possibly hardware-related with the iPad.

Yep. It could be something to do with ARKit integration - probably worth a CoSpace dev taking a look @Coralie

Geoff @ TechLeap

1 Like

Thanks @techleapnz !
I’ll message Coralie and see if they’re willing to take a poke at it.

1 Like