Can't get Camera to detach from a parent and then still be able to move


#1

Hi,

I have been having trouble with getting my camera to attach to an object and then detach from it and still be able to move. In this particular scene, I have attach to a horse (sort of lol) and then when you click the horse, it detaches. Originally, I told it to go to a certain position when it detached, but then it started being really weird when I tried to move. Then I took away that block and just told it to detach from it’s parent (the horse). That worked fine and it didn’t glitch, but I wasn’t able to move anymore. I don’t know why this happens. Is the camera perhaps stuck on Fixed mode? If so, how do I change it back since I can’t switch cameras in Blockly currently. Thanks!


#2

Hi @Alexa_Schehrer,

When you parent (attach) a camera to an item it automatically changes to the 'Fixed' movement mode, and right now there are no blocks that allow you to change the camera mode. Creating a ‘mount up / dismount’ behavior is tricky with those limitations.

However, we have a change camera - block in the works which will be released with our next update in the next few weeks. That block will help you achieve the correct behavior :slight_smile:.

Check out this thread to preview the block!