CoSpaces Black Screen of Death

Hi there,

I have a project of mine that loads into a Black Screen whenever I try to open it now. An hour ago, I was able to open the project and add new assets into it. Though, whenever I tried to play a scene in the project, it would crash, and m web browser (Microsoft Edge) would give a “Out of Memory” error. A quick refresh usually fixes it, until it crashes again.
I presume that my project is too overloaded with asset and that is why it is loading up into a black screen of death. Could help me and provide a fix?

p.s. I am unable to provide a share-link to the CoSpace as it shows a full black screen .

Hi, can you try opening your space on the Firefox or the Chrome browser? We recommend using the latest version of these browsers to make sure that CoSpaces is running smoothly.

Please let me know if using these browsers allow you to create a share link to your space.

Hi there, I did open my CoSpace on both the latest versions of Firefox and Chrome but it still shows a full black screen - I am unable to provide a share link.

Hi,

Are you able to have another teacher look at your space and open it in your stead to create a share link?

Yes, I have asked a teacher to look at the CoSpace but he too had the same problem. A full black screen with no way to share the CoSpace. Is there any other way to retrieve the CoSpace?

Hi @GerJin,

I will be in touch with our developers to see what can be done to restore your space. This could take a while. I will let you know when there’s an update :slight_smile:

Ok thank you! I will wait for your reply

Hi @Stefan

This does make me wonder what can be done to prevent such memory overloads from occurring, like a really basic performance monitor bar which could go from green to orange to red as students increase load. Education around this is obviously important, but there will be teachers who are unaware.

Maybe a good Tuesday Tip?

Geoff @ TechLeap

Hi @techleapnz,

That’s a great idea! Understanding how a space performs on devices is indeed an important bit of information to have when you want to create something that is shared in the gallery. I’ll bring your idea up with our team.

I’ll also mark this thread as solved; the @GerJin’s issue was identified and fixed.

1 Like