Importing objects from Poly Google


#1

Hi all - Poly Google is a great resource for additional objects and importing them on my laptop works great! However, I have yet to complete a successful import on a Chromebook. Well…I can import an .obj but that just produces a gray object. Attempting to import both the obj and mtl files does not work - I just get stuck on “custom model upload…uploading model”. I’ve left it for 15+ minutes (low poly item) with no results. Anyone encounter this problem? Better yet, anyone have a solution? :slight_smile: Thanks in advance!


#2

Hi MBridges,

make sure to select both .obj and .mtl file at the same time when you drag the files into your CoSpaces window. if the upload is stuck or does not continue, ensure that you have a stable internet connection and try again.

If the problem persists, please share .mlt and .obj file with us so we can look into the source of the problem!

Below is an example .gif for how it should look like.

Expand .gif


Create & Upload Animated Characters?
#3

Thank you, Stefan. I can import successfully on a laptop but not Chromebook. Not sure why. I neglected to attach this screencast to my original post:
I have tried many times with many different objects from poly google. None have been successful. I also tried from school and from home in case it was a network issue. Again, no success. Don’t understand why the Chromebook itself would be the issue but I’ve not come up with any other explanation. Thank you!


#4

I am having this exact same issue @MBridges. It doesn’t matter which file or what network connection, I get stuck on the uploading model screen. I have no problem uploading the same file to the same VR space on the same network using my Mac so I know it’s the Chromebook that’s the issue.


#5

Hey @MBridges and @powhatanschool

The problem is you are trying to drag the files from a ZIP archive directly onto CoSpaces space. That won’t work on Chromebooks. Make sure you drag the files form the expanded ZIP archive into your Downloads folder first, and then drag them onto CoSpaces. That works fine.

So the steps for Chromebooks are:

  1. Download model from Poly
  2. Double-click downloaded ZIP file to mount/expand it
  3. Select files in ZIP archive and drag them into Downloads folder
  4. Select files in Downloads folder and drag them onto CoSpaces space

Hope this helps!


#6

@MR_AzzA, that’s exactly what I had tried doing on the Chromebook. :confounded: Do you have any other suggestions?


#7

@powhatanschool That’s strange… Works fine for me on my Chromebook. Maybe the model you are importing is huge? How big is the OBJ file? If you let me know the URL of the model on Poly I can try importing it into a space to see if it works.


#8

@MR_AzzA
Here is the one we just tried this morning — https://poly.google.com/view/caxos24uWC9

We used the downloaded OBJ file. It worked with no issues on my Mac, but just keeps loading and loading and loading forever with my student’s Chromebook. We’re on the same network connection too, but still having issues. :sob:

Thanks so much for all of your help!


#9

@powhatanschool I had no problem with the model - it uploaded within seconds on my Chromebook. Are you sure you are not trying to drag the model files from mounted archive onto your space? Only dragging files from a LOCAL folder (like Downloads, or an SD Card) will work. If you saved the files into a folder in My Drive in Files app - that won’t work either most of the time. The files have to be in a local folder on the Chromebook.


#10

@MR_AzzA
Ugh, we’ve been using the downloads folder for our object files. It still just loads for hours.

Our school’s Chromebooks just don’t like CoSpaces for some reason. :cry:


#11

Hi @powhatanschool!

Could you share us the model name of your student’s Chromebook? We’d like to take a look at the model and see if this is a problem related to that particular Chromebook.


#12

Thank you @powhatanschool for confirming you have the same issue as I do! And thanks @Stefan for following up! My students use HP Chromebook 11 G5. Curious to see if @powhatanschool uses the same!


#13

@Stefan and @MBridges – We have the Acer Chromebook 13 C810 model at our school. Thanks so much for everyone’s help and input!


#14

Also I use Poly google all the time for 3d Model and Just drag them in seconds in the cospaces . Never I haven’t any problem with chromebook in this issue .
hope you will find the solution to your problem
thanks


#15

I’ve had similar issues but now resolved the upload hangup. However, if I try to upload both the .obj and .mtl file, the squirrel is all black. If I only upload the .obj file, the squirrel is plain white as expected. Any thoughts on that?


#16

Same - sooo frustrating right now. The lab I’m teaching in has PCs (Win 10) and no one has been able to bring in Google Poly object into their CoSpaces. It’s also a problem when exporting OBJ files out of Tinkercad.com (they don’t drop in either). I can do it without a problem on my Mac. It should be OS-agnostic (I would think…). Would love to hear ideas, etc. I’ve tried 3 different browsers to no resolution. Thanks!


#17

Hi @Charles_Harvey,

could you link us the files you tried to upload? We’d like to take a look at them to determine what’s the root cause of the problems.


#18

Obviously you’re extracting the zip folder from poly if you’ve gotten it to work on other platforms…