Problem with camera


#1

Good afternoon
When I put the camera on the walk mode it seems to be working automatically and I can not control it to go through the scene . and also with fly mode not good.
and also as you see the scene is very big how can I edit it to be good and how to adjust the camera in order to have a good view .
I will be very grateful to you if you could help to solve this problem .
this is the link


I am new with cospaces and this is the first time that I use it
thanks


#2

Hey yasmeen,

I looked at your space and was able to locate the problem. The camera is behaving like this because it reacts to the physics in the scene, meaning it can fall down or collide with other objects. I found a very large object in your space that is scaled so big that all the other objects are inside this object. It is called “Elephant”, if you delete it, the camera will behave as expected again.

To delete this object you need to go to the hierarchy view by clicking the three dots on the left side of the screen underneath the home button. Then you click the three dots right to the thumbnail image to open the hierarchy. Here you navigate down to find the object called “Elephant”. I drew you a red arrow to show which object is the one that’s causing the problem. If you click the three dots of this object now, you will find the option to delete it, it’s the trash can icon in the menu that opened.

With this object deleted, your camera should behave normal again.
I hope this helps, please don’t hesitate to ask if it does not work! :slight_smile:


#3

Good night Simon
Thank you very much and I appreciate your help , it was very useful and the camera returned to behave normal and I learned a lot from your notes , but the size of the scene is still big and I am afraid that there is no way to fix it . I tried to enlarge the stage area in order to leave distance between the camera and the design but Unfortunately I had read somewhere in the forum that is not possible to enlarge the stage area . I hope that you have some idea to help .
Anyhow can you please tell me if there are any rules to follow when we are designing , such as leaving a certain distance between the camera and the design or where to be the camera in order to have good work and avoiding this situation .
and I have something strange this time and I don’t know how this happened the camera exist in the stage but its shape not appear I just find it from clicking its name from the list name of the objects which appear after clicking the three dots in the left side of the screen .
thank you very much and forgive me for bothering you again
my greetings


#4

Hey Yasmeen,

Glad to hear it was helpful!

Indeed, changing the size of the building area in a space isn’t possible. A workaround would be to scale all your objects smaller. You can select all objects by dragging a selection box with your right mouse button and use the scaling button. Keep in mind that the camera can’t be scaled, so if your world is getting too small, it will feel like you’re a giant!

When you set up a scene, the camera should not be stuck in another object but should have some small space around it, so that the physics can work correctly.

Regarding your issue with the camera, I checked the space and for me, it seems to be working fine. Is it possible that the camera is just hidden behind other objects?

Let me know if this solves the issue or if you need more support. Thank you!


#5

Hello Simon
I am very grateful for your help and support , I duplicate the scene and resized the building area as you suggested in the 2nd scene it went better and I think I am happy with this size but as you see the camera stuck in the front of the scene I want to go through the area to see all the objects I want to turn around the building area from right left back front over down I want to see the view from all directions not just from the front .
I thought that may be I need to resize more so I duplicate the scene again and I resized it more in the 3rd scene but I found that doesn’t make any difference .
I changed the camera mode from walk to fly but doesn’t help .

I will appreciate your support and your patience with me until this problem is over .

my warm greetings


#6

Hey Yasmeen,

To navigate around more freely, you could set the camera to orbit mode and test, if this is more like the behaviour you need for your scene.
If you want to navigate your scene in play mode like you do in build mode, you can also just delete the camera.

Does this solve your problem? Please let me know. Thank you.


#7

Hi Simon
sure this solve this problem thank you very much , really I expected that I need to delete the camera but I am afraid that may be something wrong .
Simon really I appreciate your cooperation and patience but always happened something strange with me may be because I less experience which always force me to ask your help .
for example while I coding the animals in the same space which the same for all the animals just different with the name of the animal , so and because the procedure to repeat the codes is too long and hard , I though why I am not duplicate the codes and just change the name of animal where is needed , so i duplicate the codes of the dog and going to change the word dog to parrot for example but when I played the space all the names changing to dog again I edited the codes many times but always turned to dog with play mode I deleted all of them but also with play the deletion return back I did it many many times but still the same then I log off and log in until the deletion had been accepted and I restart again from scratch coding the animals one by one
I wrote to you in order if you have any Clarification for this issue .
thank you very much
have a good night


#8

Hey Yasmeen,

Could you please share a screenshot or a link to your space with me so I could have a look what could be causing this problem? Thanks!


#9

Hi Simon
I am sorry since I couldn’t solve the problem I deleted all the blockly and restarted from the scratch so I haven’t anything to show , but this problem always happened with me even when I try to duplicate an object in the building area , cospaces accept the first object and ignore anything about the duplicate one and also very difficult to clear it so I stuck and force to open new space to exit from this issue .
and this is what happened with me when i duplicated the blockly code cospaces just kept the same information and not accepted the changes in the duplicated one . and also I couldn’t clear ,all the time I deleted the duplication and returned back when I played the space .
and one time when I tried to duplicate blockly code , the say blockly blocked and I can’t edit it and some objects in the building area disappeared . as in this spaces


and this is the link for original space to see the difference .


thank you very much
and very sorry to bother you all the time
my best wishes


#10

Hey Yasmeen,

Thanks for attaching the screenshot. Indeed I can see now that something there does not look correctly.
Also it looks like the gifs in your scene are also not working.

Which browser are you using?

I tried your space in Chrome and Firefox, both were working fine for me. Can you try using one of these browser?

Please tell me if it works with a different browser. Thanks!


#11

Good evening Simon
You are right I tried chrome browser and the space worked very good so the problem belongs to the browser not to the space.
thank you very much
really I am grateful for your help and support
my greetings