Problem with the cospaces forum?

Hi @Stefan @Coralie , Could you please tell me why the forum doesn’t open in G Chrome while it opens in FireFox ??

Here is what it says :

@tajajtsidi @Stefan @Coralie

  1. Reload the page. This is a quick and easy troubleshooting option. Close and reopen your Chrome browser and load the page again. Something may have been off with your browser, or the site owner might have been reissuing their SSL certificate.
  2. [Public Wi-Fi network issues] When you use a public Wi-Fi network, such as in a restaurant or airport, you may receive a Chrome privacy error if you log in to a website before accepting the location’s terms and agreement. Navigate to a non-SSL site such as, and the sign-in page should open. Try the website again and see if this solves the problem.
  3. [Clear the browser cache and cookies] Clearing the browser cache and cookies is another quick and easy troubleshooting method that may solve the problem.
  4. [Open the page in Incognito mode] On a PC or Mac computer, open the page in an Incognito window. If the page opens, it likely means a Chrome extension isn’t working right. Disable the extension and open the page again normally.
  5. [Check the computer’s date and time] An incorrectly set date and time on your device can prevent Chrome from verifying the SSL certificate of the site you’re visiting. This is because when Chrome checks the expiration date of an SSL certificate, it compares it to the time on the computer’s clock.
  6. [Disable antivirus software] As antivirus software becomes more advanced, it adds new features to protect against the latest threats. One such feature is a firewall that blocks sites not secured with SSL. While this is usually good, it can sometimes conflict with your network settings and mistakenly block some SSL certificates and connections. To see if this is the problem, temporarily disable the antivirus software’s SSL scanning feature.

Please mark the answer how solved and cite me :slight_smile:

1 Like

Thank you for your answer but NONE of these works except that the forum opens in Chrome incognito mode and not in normal mode.

Which extension are you talking about here. I have only three extensions running, I disabled them but the website still not opening.

What’s the Wifi your using? It could be a managed wifi

I am using my own internet line through a Wifi router.

Huh. Unless your guardian set up some kind of internet thing, then it might be a personal issue

But it woks before. this thing is happening since the past week.

@tajajtsidi Try Incognito Mode
Clear Your Browser cache and cookies and consider what WiFi is in use.

The extension you have to check it you can be a Chrome add-on (go to “Manage extensions”).

Hi @tajajtsidi I can always open the form. I just change my G - account as I registrated the first time as CoSpaces Ambassador with a different account. Just another idea update your Chrome. Succes :four_leaf_clover:

I created a new Chrome profile. That’s how I solved the prob.
Thank you for everyone. :clap: :clap: :clap:

1 Like

Congratulations :muscle::muscle::muscle:

This happens because Chrome considers the forum unsafe. @Coralie

I never had any problems with Chrome usi g CoSpaces.