Vehicle with Camera not following Roller Coaster path

My students are working on creating roller coasters by choosing a vehicle, attaching it to the path, attaching the camera to the vehicle and coding the whole thing to go around the path in a forever loop. In some roller coasters, the vehicle seems to be following an invisible path way to the side of the actual one and on a slightly different up and down cycle. We’ve tried switching vehicles, tweaking code, and nothing helps. The exact same code works in different spaces. Does anyone know why this happens or how we can fix it?

Hi @Emily_JacksonSanborn,

There’s currently a bug in the system which occurs when the vehicle is attached to the path (but will be fixed in a future release). Detach the vehicle from the path, and it should work fine :slight_smile:

If this fixes your problem, please mark as solved.

Geoff @ TechLeap

PS: you can still keep the camera attached to the vehicle.

1 Like

This worked, thanks!!

Hello Emily_JacksonSanborn,

thank you for reporting! This problem seems to be fixed a couple days ago and fix was deployed on server recently.

Now it should work. So you can move objects attached to path without any rectrictions.
It would be nice if you give us feedback if this fix helps you.

Thank you and sorry for inconvenience!