3D Model upload troubleshooting collection

You can use this thread to share models with us that do not display in CoSpaces properly after they were uploaded. As a reminder, you can check out this tutorial post on how to upload custom 3D models to CoSpaces.

How to report faulty custom models

Most errors that happen are written down in the exporter log. After the model upload completes, you can press the exporter log button and review the messages there.

Submission format

Please attach the following to your post when reporting a 3D model:

  • 3D model file (+texture)
  • Exporter log
  • Share-link to the space where the model was uploaded to (optional)
1 Like

Dear Sir
i am unable to display texture of my 3D model (which i purchased). enc are the source files. seek your advice. thanks much.

link to source files of model which i purchased:
https://app.box.com/s/c72qhl91oa1gng93iz863axa78jrlk96

Hi @el2020,

Thanks for sharing the model! We’ll look into the issue

Hi @el2020,

Your 3D model is missing the .mtl - file that connects the textures to the 3D .obj models. You need to drag & drop the .obj file, .mtl file and texture files into CoSpaces at the same time. Please make sure that you also received the necessary .mtl file to your model.

Thanks much for reply. here are the files. I still have issues displaying the texture in co-space. can seek ur help?

https://app.box.com/s/ahpj5509gjc3aahbjphg6innz7cxcgko

https://app.box.com/s/c72qhl91oa1gng93iz863axa78jrlk96

dear stefan, can seek ur help?
https://app.box.com/s/ahpj5509gjc3aahbjphg6innz7cxcgko
https://app.box.com/s/c72qhl91oa1gng93iz863axa78jrlk96

Hi @el2020,

Below you can find a compatible version of your 3D model. Simply drag & drop into CoSpaces :slight_smile:

liftTraction.zip (4.5 MB)

thank you very much sir. much appreciated. it’s working now.

rgds

1 Like

hey! I am having some issues with the texures. Whenever I use .obj + jpg, jpeg, png, the model is just white, the textures only work if I have just a .obj + .mtl

Any solutions ?

Thanks a lot!

Hey!

here is the space:

Here is a link with my object and textures! https://drive.google.com/drive/folders/1l_NKmVeA3bMwC_PukyGL4Oz2ljlzjDsU?usp=sharing

this is the LOG:

Exported models:
valora

Run FBX exporter
1 files will be processed: valora.fbx
TimeStep = 1539538600
found model valora
Export animation from animation stack: Take 001, animation name = take 001
found skin: F_MED_Valor_01_Export
found skin: F_MED_IND_Valor_Head_01

Loading model valora …
No collision capsules found, using mesh bounding box for collision
skins: [F_MED_Valor_01_Export, F_MED_IND_Valor_Head_01]

writing mesh F_MED_Valor_01_Export:

  • part F_MED_Valor_01_Export0, numPoints = 2349, numFaces = 4049, type = POINT3_NORMAL3_UV2_W4
    , clusters.length = 40, material from fbx: objMtl = 2OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–, node = F_MED_Valor_01_Export
    writing mesh F_MED_Valor_01_Export:
  • part F_MED_Valor_01_Export1, numPoints = 1306, numFaces = 2237, type = POINT3_NORMAL3_UV2_W4
    , clusters.length = 40, material from fbx: objMtl = 2OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–, node = F_MED_Valor_01_Export
    writing mesh F_MED_Valor_01_Export:
  • part F_MED_Valor_01_Export2, numPoints = 1304, numFaces = 2189, type = POINT3_NORMAL3_UV2_W4
    , clusters.length = 40, material from fbx: objMtl = 2OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–, node = F_MED_Valor_01_Export
    writing mesh F_MED_Valor_01_Export:
  • part F_MED_Valor_01_Export3, numPoints = 810, numFaces = 1254, type = POINT3_NORMAL3_UV2_W4
    , clusters.length = 40, material from fbx: objMtl = 2OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–, node = F_MED_Valor_01_Export
    writing mesh F_MED_Valor_01_Export:
  • part F_MED_Valor_01_Export4, numPoints = 1164, numFaces = 1988, type = POINT3_NORMAL3_UV2_W4
    , clusters.length = 28, material from fbx: objMtl = 2OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–, node = F_MED_Valor_01_Export
  • part F_MED_Valor_01_Export0, numPoints = 1788, numFaces = 2897, type = POINT3_NORMAL3_UV2_W4
    , clusters.length = 9, material from fbx: objMtl = 2OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–, node = F_MED_Valor_01_Export
  • part F_MED_Valor_01_Export0, numPoints = 674, numFaces = 1144, type = POINT3_NORMAL3_UV2_W4
    , clusters.length = 10, material from fbx: objMtl = 2OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–, node = F_MED_Valor_01_Export

writing mesh F_MED_IND_Valor_Head_01:

  • part F_MED_IND_Valor_Head_010, numPoints = 3235, numFaces = 5760, type = POINT3_NORMAL3_UV2_W4
    , clusters.length = 32, material from fbx: objMtl = 2OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–, node = F_MED_IND_Valor_Head_01
  • part F_MED_IND_Valor_Head_010, numPoints = 3429, numFaces = 5716, type = POINT3_NORMAL3_UV2_W4
    , clusters.length = 20, material from fbx: objMtl = 2OlZWVAAGGQAmZ–OlZWVAAGGQAmZ–, node = F_MED_IND_Valor_Head_01

Fbx model “valora” has successfully exported
JetRecord: size = 1161k, header: 3667 bytes, 3493 floats, 345 doubles
Animations:
take 001 [0 … 289433256800]
13/143 node(s) optimized
Fbx model: faces 27k, points 16k, data size 999k
Parts for valora: F_MED_IND_Valor_Head_010,F_MED_Valor_01_Export0,F_MED_Valor_01_Export1,F_MED_Valor_01_Export2,F_MED_Valor_01_Export3,F_MED_Valor_01_Export4

Exporting FBX files ended

Output model name: [“valora”]
Result files:
/tmp/tmp13715552875747644909.tmp/valora_a1brg4p727rrgmtigqujpbeg.jet, size: 1188992
/tmp/tmp13715552875747644909.tmp/valora_a1brg4p727rrgmtigqujpbeg.json, size: 142

1 Like

Hi @Robert_Brez,

Thanks for sharing! We’ll look into this model :slight_smile:

1 Like

dear stefan

can seek your help to tweak the enclosed intercom 3D model? i can’t seem to get it correctly uploaded / displayed. thank you.
Uploading: intercom_ALB.png… Uploading: intercom_NRM.png… intercom_ts.obj (7.1 KB)

Hi - When I try to import this OBJ files from sketchup the walls of the house do not appear. I am not sure what I am doing incorrectly. Since I am a new user I cannot upload the files to share. Any advice you have would be great. Thank you!!

Hi @Danielle_Mirliss,

I’ve just changed forum settings to allow new users to upload up to five attachments to their posts. Please post the files that are causing problems. Thank you.

Thank you! The files are too large to upload so I created a shared link to my drive: https://drive.google.com/drive/folders/1QyEvYKrDh9cBhjfjdy7xY4edokkhYnEW?usp=sharing

For me the problem with importing such an object with textures was solved by dragging all the files together to the uploadspace. When i didn’t the texture didn’t appear.

Thanks for the suggestion. I will go back and make sure that I am uploading everything corectly. It just seemed strange that some textures were appearing correctly and others were not.

Hi Pavel,
Just checking to see if you had any insight into the issue I was having with some textures not appearing when I imported a sketchup file into cospaces. Here are the files: https://drive.google.com/drive/folders/1QyEvYKrDh9cBhjfjdy7xY4edokkhYnEW?usp=sharing

Hi @el2020,

The files you shared are missing texture-files. Were you provided any .tga, .png, or .jpg textures with that asset?

Hi @Danielle_Mirliss,

The files provided in the google drive link are missing the texture files (they come in .tga, .png or .jpg format). Please check if you are able to also download the house textures of the model.