3D Model upload troubleshooting collection

Hi Pavel,
Just checking to see if you had any insight into the issue I was having with some textures not appearing when I imported a sketchup file into cospaces. Here are the files: https://drive.google.com/drive/folders/1QyEvYKrDh9cBhjfjdy7xY4edokkhYnEW?usp=sharing

Hi @el2020,

The files you shared are missing texture-files. Were you provided any .tga, .png, or .jpg textures with that asset?

Hi @Danielle_Mirliss,

The files provided in the google drive link are missing the texture files (they come in .tga, .png or .jpg format). Please check if you are able to also download the house textures of the model.

Sorry about that, I have uploaded all of the texture files to the google folder. I tried to drag them all on the stage (except for the skp and stl - but I inlcuded these in case you need them). Thanks for your help!

Hi - Just following up on my issues with the textures from Sketchup importing into CoSpaces. I know there are a lot of texture files, just wondering if that is the issue. Thanks!!

Hi @Danielle_Mirliss,

We investigated the file and noticed that the best way to prepare your SketchUp file for CoSpaces is with these export settings:


Export the file as .obj, click Options... and set the export settings as shown above. Once the files are exported (.obj, .mtl, and texture files), place all of them in a single folder and .zip them together. Then drag & drop into CoSpaces Edu.

Below is a remixable space with your Dream House :slight_smile:

We noticed that complex floors and items “glued” to floors are not properly exported sometimes. To fix that in your example, we had to turn the carpet under the bed into a component so that it is not glued to the floor anymore. (see video example below)

Hope this helps with your SketchUp models!

1 Like

I would not recommend using “two-sided” export in general. It doubles the amount of model triangles, increases load time, and reduce performance.

This is only for ill-formed model.
Usually, models are good.

I am having trouble importing files. I have tried lots of them. FBX, OBJ + MTL, + textures TGA, PNG and so on. I have tried files I have found and also some of them that you guys said is compatible. The models work fine but the texture is missing on all of them. Here are all the models I have been trying to upload.

liftTraction.zip (4.5 MB)
Arquivo Comprimido.zip (1.2 MB)

Hi @CCBEU_Guarapuava,

We reviewed the 3D models and noticed that the Gas station - model did not have textures properly assigned.

Below is a remixable space with the corrected assets. You can copy + paste these items through scenes via CTRL+C and CTRL+V (on mac: CMD + C, CMD + V).

Or drag and drop the fixed .zip files into your scene:
GasStation.zip (1.2 MB)

LiftTraction.zip (701.5 KB)

Hi, @Stefan!

UPDATE: It seems that when I pull the model into the space, it starts below the ground. So I have to lift it up to see it properly. However, the Exporter Log is confusing because it says "The models couldn’t be uploaded."

I’m trying to upload a 3D model that i created using the Qlone iOS app. OBJ zip attached.

When I upload it into CoSpaces Edu (using drag/drop and upload button options), it does not upload. I see this Exporter Log:
35%20AM

Here is my OBJ zip file I’m trying to upload into my MERGE Cube Space:
Spongebob 3D.zip (1.5 MB)

I’m able to upload the example 3D model in the Qlone app (the elephant):
New Qlone 2.zip (5.1 MB)
But I can’t upload my own scan from Qlone into CoSpaces Edu.

Hi @EdTechnocation,

Thanks for the report! We’ll look into this strange upload message and work on making sure that uploaded items are always seen on the floor after the upload!

1 Like

Please find the .FBX here https://www.dropbox.com/s/5q716qojybsrdpv/A.fbx?dl=0

When I try to upload this custom object, it says Couldn’t be uploaded.

Please Help.

Hello!
I need some help uploading this model
gork.zip (2.7 MB)

If I try uploading the .obj + .mtl + textures, some textures don’t show correctly. If I try the zip folder, it shows this message
image

I also tried .FBX but it didn’t bring any textures.

I’d appreciate any help. Thanks!

Hi, Rosa! I was running into this same problem. I received that same message BUT the object was actually uploading into my space. The problem was that the object was uploading below the floor! So I couldn’t see it. The message is misleading and I’ve shared it with the team. Try again and see if the object did actually upload, then raise it above the floor.

Hello @Rosa_Cendros,

Below you can find a remixable space with your uploaded item. Sometimes, uploads fail due to connection issues. Make sure that you have a stable internet connection :slight_smile:

Note: You can copy and paste this item through different scenes! Simply select the item in your remix-copy, and use keyboard shortcut CTRL + C (on mac: ⌘ + C) to copy the item to your clipboard, and paste it in a scene via CTRL + V (on mac: ⌘ + V).

Hope this helps!

Hello! I have trouble uploading my 3D Model created from TinkerCAD. It says successful but when dragged it does not show the model. Thank you in advance! Below is the file I’m trying to use.

Book Shelf Red orange (3).zip (517.8 KB)

Hey @Gerald_Dino,

Your object has a wrong pivot point, so it ends up below the floor in CoSpaces. Just pull it up above the ground after you uploaded it or change the pivot point in TinkerCAD and it should work!

I hope that helps!

Thank you so much! It did work! Thank you for that fast response!

Hi! I am having trouble uploading any textures (like .mtl files) into a Cospace. It just lets me upload a .obj and doesn’t render any textures. When I try to upload a .zip file, I get a ‘check your internet connection’ error.

Files:

Hoping to get help from this forum. Also keen to know how to work around it without having to post on this forum!

Thanks,
Shambhavi

Hi there-
Having difficulty uploading an FBX file from Google Tilt Brush.
I have created a simple model here (tried to avoid dynamic, translucent brushes etc.) but when I upload, the object is displayed without any of the color information. I am not seeing any other files in the export that may support the surface colors. The export log only shows the following:


Here is the FBX file: drogonfly.fbx (548.3 KB)
Test space with file in it: https://cospac.es/dIy4

Thanks for any help or advice you can offer!
Best,
Greg