3D Model upload troubleshooting collection

Hello, I can’t seem to upload any files with OBJ and MTL files. They all appear white.

I tried dragging and dropping along with upload.

Here is a zip of one file I have tried.

Any ideas?

house 3.zip (36.5 KB)

Thanks,

Wayne

For some reason in your files material file is named incorrectly. I renamed it so it matches the name from obj file and it works.
house 3.zip (30.8 KB)

I just downloaded your zip and it did not work for us. It still shows up grey/white. I renamed both files house and still have the same issue.

We tried drag and dropping both files, drag and dropping zip file, and uploading both files/ uploading zip file.

:-/

Here is the house we are using the most. I checked the file names and they seem to be correct. Still white :-/

50-fantasyhouse1 2.zip (1.0 MB)

The first house’s material is grey. The fantasy house archive contains non-standard material file. The material file should be in ASCII format.

Please, check the source of your files.

No, this files are not correct. The .mtl is not correct.
You can read about what MTL should be here:

I am working on an AR project for WWII and I am having trouble getting this model in as either - ZIP FBX https://drive.google.com/file/d/12rVuVXXGYEngyxQgTWR6QkhAjjXv5OIM/view?usp=sharing
I load the model, but it seems to just bring the object in, no color and no texture. I tried extracting and uploading without the unsupported metallic file, but still not working. I paid for this from Sketchfab: https://skfb.ly/TEYo, so please do not download for personal use. Somewhat pressing issue as I am trying to get this scene finished by Monday deadline.

I just gave access, sorry about that.

Hey @Kevin_White ,
I looked into the file and I think the textures where not properly linked to the model, that’s why it did not work. I assigned the texture and uploaded the model, you can remix it from this CoSpace:


I hope it helps, let me know if it does not work!

Hi There,

I try to upload a OBJ+ MTL file made in Doodle3D (https://transform.doodle3d.com/)

The material colour are not visible after importing the model. I opened the model in Sketchfab here the colours are visible so it looks like the export is correct.

Maybe you guys can figure out what is going wrong :slight_smile: I added my test model and log and test Test_Doodle3DQR space in the attachment

Leg_art.zip (1.8 MB)

Thank you for posting this models. We found and fixed a bug with the materials. Your sample will work correctly with the next release

Thats Awesome :slight_smile: Thanks for the fast reply :+1:

Thanks for going out of your way. Any chance you can send me the files you fixed?

I am also trying to get this one in. Same issue. Oddly, I used this same artist, he had packaged the last 2 models the same way, but they both went in without issue.
It would be really great if CoSpaces could do a webinar on 3D uploads and post it to YouTube. I don’t know what the difference is between a lot of these files.
https://drive.google.com/file/d/19P7zvebp8lGAusIC3IUQgt-8_oR20Gdm/view?usp=sharing

Hello
I used these object in my project but it did not show the color Is there a way or Any thing to do I am participating in a workshop and I want to include this object

Could you please attach a model file, so we could investigate a problem?

1 Like

We have identified and fixed a bug that caused your problem. Please, try to paste this object now.

The problem is still the discoloration but the object’s shape cannot be preserved

1 Like

Hi, the normals of the head are inverted. This is set in the model and should be fixed there

upd: the obj file has normals set up properly, and the fbx file has wrong normals. You could use obj file or fix the fbx.