Cannot see the texture after import of a 3D model

Dear Cospace,

We are importing a Chinese temple into the space but we find that the texture cannot be shown. We have tried numerous methods and seems no luck still. Can you please help have a look if possible? Thanks. (4.2 MB)

Best Regards
Ivan Ng

1 Like

Hi @Ivan_Ng,

I had no trouble uploading your 3D model. Here’s what I did:

  1. Downloaded your zip file
  2. Extracted all the files from the zip file
  3. Went to Upload > 3D Models and clicked Upload
  4. Selected all images, OBJ and MTL files, and uploaded to CoSpaces
  5. Dragged the resulting object into my CoSpace

You can see the result here:

Hope that helps! Let me know if you have any further questions.

Geoff @ TechLeap


Thanks a lot Geoff. I tried with another sample and hit another issue (this time it seems that the file cannot be imported at all). Appreciate if you can offer help on this as well if possible. Thanks again for your great help! (14.7 MB)

Hi @Ivan_Ng,

The size of the OBJ is 74MB - the maximum upload size for a file on CoSpaces is 50MB. If my previous answer solved your issue, please mark it as Solved.

Many thanks,
Geoff @ TechLeap

1 Like

@techleapnz ,
Could you try to embed objects from MakeHuman?
An italian teacher said me that her humanoid is completely white!

Hi @Bettananni

I was able to export a MakeHuman model as FBX and import with textures successfully, however I had to copy the textures into the same folder as the FBX file and upload those images at the same time.

Hope that helps! Let me know if you have any further questions about this.

Geoff @ TechLeap


Thank you, @techleapnz !
I immediately report to my friend :wink:


1 Like

I’m having the same issue with an OBJ I downloaded off of Sketchfab. I can unzip it and upload the OBJ and it’s a completely white model without the texture. I tried uploading the texture file with it but that didn’t work. This is my first time going through this process so any help is appreciated.
Here’s the OBJrickastley.x.obj (992.8 KB) :
And here’s the texture jpg:

Hi @Drew_Gollias,

Is there a .MTL (material) file which goes with it? This file usually contains references to external images and other files used for textures.

Geoff @ TechLeap

Hey, Geoff, thanks for responding, I appreciate it. It came in two folders. The obj file above and then the jpeg in a separate folder, but no MTL. Unless I’m doing something wrong. Here’s the sketchfab link I’m using:

I had no joy with this either - tried importing into Blender too. Will have another go later in the week.

Thanks so much for trying, Geoff, I appreciate it.

I’m having trouble importing these models every time I extract them or try to collide them it only accepts the model, not the textures. Help! (4.7 MB) (6.4 MB)

hello @Quinn_Kelm, here the second object that you sent. There wasn’t any mtl file that the software need to assign the correct textures. I shaded it with diffuse, normal and metallic texture and edited the respective .mtl file.
With the first file (Super Mario) I had problem.
Hope this helps, Giuseppe (3.9 MB)


Hi @Quinn_Kelm, here it is your SuperMario, the fbx model was split in four different objects (I don’t know why!). (2.3 MB)