Urgent Help with coding/animations

Hi everyone,

I hope someone can help me. I am designing a game for a pilot program to get some funding for VR for my school. We are using Meta Quest 2 to play these games in VR and have recently downloaded the CoSpaces app.

I am having an issue where I code something on the computer and it works perfectly, but then when I go into the app on VR or cellphone, my animations/code will not work. It is an obstacle course. I tried playing on the Meta Web browser and the game works.

But I just don’t know why it won’t work on the actual app. Can anyone please help?

This is the game link: CoSpaces Edu :: G4 Science U16 VR Game 6

Hi @Davin_Karatouliotis, this is probably something the @CoSpaces_Edu dev team should investigate.

Thanks for tagging us @techleapnz - @Davin_Karatouliotis we’ll take a look at this for you!

1 Like

Thank you for your response. I sorted out the problem, but maybe this is something the dev team can look into since it worked on pc, but not on any of the apps (phone and Meta app).

Basically I had attached objects to paths and coded them to move and then keep repeating the actions forever to make obstacles. What eventually fixed is was when I detached the objects from the path, but I left in my original code that I had before.

I don’t know much about coding and am learning as I go, but I am curious as to why it worked on pc, but not in the apps. Is this just some kind of bug?

1 Like

Hi @Davin_Karatouliotis thanks for letting us know! This is indeed a bug, which our devs are currently working to fix ASAP. Sorry for the inconvenience it caused you but thanks for pointing it out!