App update on ClassVR headset not working

Can someone tell me how to update the Cospaces app on the ClassVR headsets, please. Devastated students could not see their worlds because the Cospaces app said it needed updating.

1 Like

I’m having the same problem please help

@Kylie_Walters @Room13_Co Hi! We apologize for the disruption that was caused to you and your students. Are you still experiencing this issue? We encountered a technical challenge that has since been taken care of. This could have been impacting your students access to their virtual worlds. If this is still an issue though, please let us know so we can find a solution for you.

I am trying to update, and it’ keeps telling me I need to update the cospaces app. When I restart the goggles, I keep getting the message to update cospaces.

I am having the same issue. I can connect to CoSpaces but I get stuck in the Gallery and no content will load. All my other non CoSpaces content will load.


Did we find out anymore information on troubleshooting the “stuck in gallery” issue? I had about 8 ClassVR headsets today that were problematic with CoSpaces, but worked fine with all other content.

This is not ideal but this worked for me. Factory resetting the device and reconnecting it to the network, then pushing out the CoSpace app has worked.

It is time consuming as the headsets processors are slow. I was able to knock out 22 in 7 hours while trying to teach.

I have open tickets with CoSpaces and ClassVR but have not had the time to problem solve. I am just using the headsets that work right now and hoping they do not have the same issue. Planning to address this when I have time later in the year.

Here is a link to the other thread

1 Like